Warning about tropical storm Elsa
Incident Report for HotSchedules
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 03:15 CDT
Monitoring
Tropical Storm Elsa is expected to impact our offices on Wednesday, July 7th. While we will process payroll without interruption, there is a risk that shipping checks could be disrupted. To avoid shipping delays to the delivery of payroll, we are encouraging customers with a check date of July 8 or July 9 to process their payroll earlier on July 6.
Please contact your payroll specialist to expedite your payroll or if you have any questions.
Sincerely,
Your Fourth Payroll Team
Posted Jul 05, 2021 - 12:37 CDT
This incident affected: US HR & Payroll.